12
P3: WAN NETWORK DIAGRAM: I used GNS3 tool to develop this network, according to requirement of this practical; I used Frame Relay switch and 4 routers are considered name them R1, R2, R3 and R4. Each router is connected to different LAN networks namely LAN1, LAN2, LAN3 and LAN 4. STEP-1: CREATE VLSM TABLE NETWORK NAME NETWORK ID 1 st USABLE ADDRESS/DEFA ULT GATEWAY LAST USABLE ADDRESS BROADCAST ADDRESS DOTTED DECIMAL CIDR LAN-1 172.16.0. 0 172.16.0.1 172.16.1.254 172.16.1.255 255.255.254.0 /23 LAN-2 172.16.2. 0 172.16.2.1 172.16.2.254 172.16.2.255 255.255.255.0 /24 LAN-3 172.16.3. 0 172.16.3.1 172.16.3.126 172.16.3.127 255.255.255.12 8 /25 LAN-4 172.16.3. 128 172.16.3.129 172.16.3.158 172.16.3.159 255.255.255.22 4 /27 Router Interface (R1-R2) 172.16.3. 160 172.16.3.161 172.16.3.162 172.16.3.163 255.255.255.25 2 /30 Router Interface (R1-R3) 172.16.3. 164 172.16.3.165 172.16.3.166 172.16.3.167 255.255.255.25 2 /30 Router Interface (R1-R4) 172.16.3. 168 172.16.3.169 172.16.3.170 172.16.3.171 255.255.255.25 2 /30 Router Interface (R3-R4) 172.16.3. 172 172.16.3.173 172.16.3.174 172.16.3.175 255.255.255.25 2 /30 STEP-2: LAN CONFIGURATION According to the requirement, LAN is configured as shown below, 1

WAN and LAN by using GNS3 software

Embed Size (px)

Citation preview

Page 1: WAN and LAN by using GNS3 software

P3: WAN

NETWORK DIAGRAM:

I used GNS3 tool to develop this network, according to requirement of this practical; I used Frame Relay switch and 4 routers are considered name them R1, R2, R3 and R4. Each router is connected to different LAN networks namely LAN1, LAN2, LAN3 and LAN 4.

STEP-1: CREATE VLSM TABLE

NETWORK NAME

NETWORK ID

1st USABLE ADDRESS/DEFAULT GATEWAY

LAST USABLE ADDRESS

BROADCAST ADDRESS

DOTTED DECIMAL

CIDR

LAN-1 172.16.0.0 172.16.0.1 172.16.1.254 172.16.1.255 255.255.254.0 /23

LAN-2 172.16.2.0 172.16.2.1 172.16.2.254 172.16.2.255 255.255.255.0 /24

LAN-3 172.16.3.0 172.16.3.1 172.16.3.126 172.16.3.127 255.255.255.128

/25

LAN-4 172.16.3.128

172.16.3.129 172.16.3.158 172.16.3.159 255.255.255.224

/27

Router Interface (R1-R2)

172.16.3.160

172.16.3.161 172.16.3.162 172.16.3.163 255.255.255.252

/30

Router Interface (R1-R3)

172.16.3.164

172.16.3.165 172.16.3.166 172.16.3.167 255.255.255.252

/30

Router Interface (R1-R4)

172.16.3.168

172.16.3.169 172.16.3.170 172.16.3.171 255.255.255.252

/30

Router Interface (R3-R4)

172.16.3.172

172.16.3.173 172.16.3.174 172.16.3.175 255.255.255.252

/30

STEP-2: LAN CONFIGURATION

According to the requirement, LAN is configured as shown below,

LAN-1 LAN-2 LAN-3 LAN-4 WAN ProtocolHOSTS 320 130 120 30 EIGRP

1

Page 2: WAN and LAN by using GNS3 software

P3: WAN

Here in each Local Area Network; Pc’s are connected and the IP addresses assigned to each router are shown below,

LANS PC’S IP ADDRESSES/ DEFAULT GATE WAYLAN-1 PC1 172.16.0.2/172.16.0.1LAN-2 PC2 172.16.2.2/172.16.2.1LAN-3 PC3 172.16.3.2/172.16.3.1LAN-4 PC4 172.16.3.130/172.16.3.129

STEP-3: CONFIGURATION IN FRAME RELAY SWITCH

In Frame Relay Switch, I configured ports and DLCI. Now router R1 is connected to left side of the switch and other three routers namely R2, R3 and R4 are connected other side of the switch and these are mapped as below,

STEP-4: CONFIGURATION IN ROUTERS

In Router R1:

hostname R1

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

no ip domain lookup

multilink bundle-name authenticated

archive

log config

hidekeys

ip tcp synwait-time 5

interface FastEthernet0/0

ip address 172.16.0.1 255.255.254.0

duplex auto

2

Page 3: WAN and LAN by using GNS3 software

P3: WAN

speed auto

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 2000000

interface Serial0/0.102 point-to-point

ip address 172.16.3.161 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 102

interface Serial0/0.103 point-to-point

ip address 172.16.3.165 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 103

interface Serial0/0.104 point-to-point

ip address 172.16.3.169 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 104

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

router eigrp 10

network 172.16.0.0 0.0.1.255

network 172.16.3.160 0.0.0.3

network 172.16.3.164 0.0.0.3

network 172.16.3.168 0.0.0.3

no auto-summary

ip forward-protocol nd

3

Page 4: WAN and LAN by using GNS3 software

P3: WAN

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end

In Router R2:

hostname R2

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

no ip domain lookup

multilink bundle-name authenticated!

archive

log config

hidekeys

ip tcp synwait-time 5

interface FastEthernet0/0

ip address 172.16.2.1 255.255.255.0

duplex auto

speed auto

4

Page 5: WAN and LAN by using GNS3 software

P3: WAN

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 2000000

interface Serial0/0.201 point-to-point

ip address 172.16.3.162 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 201

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

router eigrp 10

network 172.16.2.0 0.0.0.255

network 172.16.3.160 0.0.0.3

no auto-summary

ip forward-protocol nd

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

5

Page 6: WAN and LAN by using GNS3 software

P3: WAN

logging synchronous

line vty 0 4

login

end

In Router R3:

hostname R3

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

no ip domain lookup

multilink bundle-name authenticated

archive

log config

hidekeys

ip tcp synwait-time 5

interface FastEthernet0/0

ip address 172.16.3.1 255.255.255.128

duplex auto

speed auto

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 2000000

interface Serial0/0.301 point-to-point

ip address 172.16.3.166 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 301

interface Serial0/0.304 point-to-point

ip address 172.16.3.173 255.255.255.252

snmp trap link-status

6

Page 7: WAN and LAN by using GNS3 software

P3: WAN

frame-relay interface-dlci 304

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

router eigrp 10

network 172.16.3.0 0.0.0.127

network 172.16.3.164 0.0.0.3

network 172.16.3.172 0.0.0.3

no auto-summary

ip forward-protocol nd

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end

In Router R4:

hostname R4

7

Page 8: WAN and LAN by using GNS3 software

P3: WAN

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

no ip domain lookup

multilink bundle-name authenticated

archive

log config

hidekeys

ip tcp synwait-time 5

interface FastEthernet0/0

ip address 172.16.3.129 255.255.255.224

duplex auto

speed auto

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 2000000

interface Serial0/0.401 point-to-point

ip address 172.16.3.170 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 401

interface Serial0/0.403 point-to-point

ip address 172.16.3.174 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 403

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

8

Page 9: WAN and LAN by using GNS3 software

P3: WAN

interface Serial0/1

no ip address

shutdown

clock rate 2000000

router eigrp 10

network 172.16.3.128 0.0.0.31

network 172.16.3.168 0.0.0.3

network 172.16.3.172 0.0.0.3

no auto-summary

ip forward-protocol nd

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end

STEP-5: WAN PROTOCOL ASSIGNED IN ROUTERS

Here, I assigned EIGRP (Enhanced Interior Gateway Routing Protocol) to advertise all networks in a router to others routers.

To restore the default behaviour of automatic summarization of subnet routes into network-level routes, use the “auto-summary” command in router configuration mode. To disable this function and send sub prefix routing information across classful networks, use the “no auto-summary” form of this command.

In R1,

9

Page 10: WAN and LAN by using GNS3 software

P3: WAN

In R2,

In R3,

In R4,

STEP-6: RESULT

Now, PC1connected to Router (R1) is pinging to IP address of PC3 connected to Router (R3).

10

Page 11: WAN and LAN by using GNS3 software

P3: WAN

Now, PC2 connected to Router (R2) is pinging to IP address of PC4 connected to Router (R4).

11