6
Case Study 1 VLANs, VTP and Inter-VLAN Routing VLAN Name 10 Red 20 Blue 30 Orange 40 Green This Subnetting scenario, we will use…… VLAN 10: 172.16.10.0/24 VLAN 20: 172.16.20.0/24 VLAN 30: 172.16.30.0/24 VLAN 40: 172.16.40.0/24 Fa 0/12 : 172.16.50.0/24 Loopback0: 172.16.60.1/24 Arbab Nazar Network Engineer B.Sc. CE, M.Sc. Computer Networks

27816536 CCNP3 BCMSN Case Study 1

Embed Size (px)

Citation preview

Page 1: 27816536 CCNP3 BCMSN Case Study 1

Case Study 1 VLANs, VTP and Inter-VLAN Routing

VLAN

Name

10

Red

20

Blue

30

Orange

40

Green

This Subnetting scenario, we will use…… VLAN 10: 172.16.10.0/24 VLAN 20: 172.16.20.0/24 VLAN 30: 172.16.30.0/24 VLAN 40: 172.16.40.0/24 Fa 0/12 : 172.16.50.0/24 Loopback0: 172.16.60.1/24

Arbab Nazar Network Engineer

B.Sc. CE, M.Sc. Computer Networks

Page 2: 27816536 CCNP3 BCMSN Case Study 1

1. Disable the links between the access layer switches. DS1(config)#interface range fa 0/7 - 10

DS1(config-if-range)#sh DS2(config)#interface range fa 0/7 - 10

DS2(config-if-range)#sh AS1(config)#interface range fa 0/7 - 10

AS1(config-if-range)#sh AS2(config)#interface range fa 0/7 - 10

AS2(config-if-range)#sh

2. Place all switches in the VTP domain CISCO. Make DS1 the VTP server and all other switches VTP clients.

DS1(config)#vtp domain CISCO

DS1(config)#vtp mode server

DS2(config)#vtp domain CISCO

DS2(config)#vtp mode client

AS1(config)#vtp domain CISCO

AS1(config)#vtp mode client

AS2(config)#vtp domain CISCO

AS2(config)#vtp mode client

3.Create the VLANs shown in the VLAN table and assign the names given. For subnet planning, allocate a subnet for each VLAN.

DS1(config)#vlan 10

DS1(config-vlan)#name Red

DS1(config-vlan)#exit

DS1(config)#vlan 20

DS1(config-vlan)#name Blue

DS1(config-vlan)#exit

DS1(config)#vlan 30

DS1(config-vlan)#name Orange

DS1(config-vlan)#exit

DS1(config)#vlan 40

DS1(config-vlan)#name Green

DS1(config-vlan)#exit

Arbab Nazar Network Engineer

B.Sc. CE, M.Sc. Computer Networks

Page 3: 27816536 CCNP3 BCMSN Case Study 1

4. Make DS1 the primary spanning-tree root for all VLANs. Make DS2 the backup root. DS1(config)#spanning-tree vlan 1,10,20,30,40,1002,1003,1004,1005 root primary DS2(config)#spanning-tree vlan 1,10,20,30,40,1002,1003,1004,1005 root secondary

5. Make F0/12 between DS1 and DS2 a layer 3 link and assign a subnet to it.

DS1(config)#interface fa 0/12

DS1(config-if)#no switchport

DS1(config-if)#ip address 172.16.50.1 255.255.255.0

DS1(config-if)#no sh DS2(config)#interface fa 0/12

DS2(config-if)#no switchport

DS2(config-if)#ip address 172.16.50.2 255.255.255.0 DS2(config-if)#no sh

6. Create a loopback interface on DS1 and assign a subnet to it.

DS1(config)#interface loopback 0

DS1(config-if)#ip address 172.16.60.1 255.255.255.0

7. Make F0/11 between DS1 and DS2 an ISL trunk link

DS1(config)#interface fa 0/11 DS1(config-if)#switchport trunk encapsulation isl

DS1(config-if)#switchport mode trunk

DS1(config-if)#no sh

DS2(config)#interface fa 0/11 DS2(config-if)#switchport trunk encapsulation isl

DS2(config-if)#switchport mode trunk

DS2(config-if)#no sh

8. Configure all other trunk links using 802.1q.

(The default encapsulation is 802.1q)

9. Make sure that all inter-switch links are statically set as trunks

(Using SHOW VLAN BRIEF)

10. The links from DS1 to each access switch must be bound together in an EtherChannel.

DS1(config)#interface range fa 0/7 -8

DS1(config-if-range)#channel-group 1 mode on

DS1(config-if)#exit

DS1(config)#interface port-channel 1

DS1(config-if)#switchport trunk encapsulation dot1q

DS1(config-if)#switchport mode trunk

Arbab Nazar Network Engineer

B.Sc. CE, M.Sc. Computer Networks

Page 4: 27816536 CCNP3 BCMSN Case Study 1

DS1(config)#interface range fa 0/9 -10

DS1(config-if-range)#channel-group 2 mode on

DS1(config-if)#exit

DS1(config)#interface port-channel 2

DS1(config-if)#switchport trunk encapsulation dot1q

DS1(config-if)#switchport mode trunk

AS1(config)#interface range fa 0/7 -8

AS1(config-if-range)#channel-group 1 mode on

AS1(config-if)#exit

AS1(config)#interface port-channel 1

AS1(config-if)#switchport trunk encapsulation dot1q AS1(config-if)#switchport mode trunk

AS2(config)#interface range fa 0/9 -10

AS2(config-if-range)#channel-group 2 mode on

AS2(config-if)#exit

AS2(config)#interface port-channel 2

AS2(config-if)#switchport trunk encapsulation dot1q AS2(config-if)#switchport mode trunk

11. Enable portfast on all access ports. AS1(config)#spanning-tree portfast default AS2(config)#spanning-tree portfast default

12. Put F0/15 through F0/17 on AS1 and AS2 in VLAN 10. Place F0/18 and F0/19 on AS1

and AS2 in VLAN 20. Place F0/20 on AS1 and AS2 in VLAN 30.

AS1(config)#interface range fa 0/15 – 17 AS1(config-if-range)#switchport access vlan 10

AS1(config-if-range)#switchport mode access

AS1(config)#interface range fa 0/18 – 19 AS1(config-if-range)#switchport access vlan 20

AS1(config-if-range)#switchport mode access

AS1(config)#interface fa 0/20 AS1(config-if-range)#switchport access vlan 30

AS1(config-if-range)#switchport mode access

AS2(config)#interface range fa 0/15 – 17 AS2(config-if-range)#switchport access vlan 10

AS(config-if-range)#switchport mode access

AS2(config)#interface range fa 0/18 – 19 AS2(config-if-range)#switchport access vlan 20

AS2(config-if-range)#switchport mode access

AS2(config)#interface fa 0/20 AS2(config-if-range)#switchport access vlan 30

AS2(config-if-range)#switchport mode access

Arbab Nazar Network Engineer

B.Sc. CE, M.Sc. Computer Networks

Page 5: 27816536 CCNP3 BCMSN Case Study 1

13. Create an 802.1q trunk link between R1 and AS2. Allow only VLANs 10 and 40 to pass through the trunk.

AS2(config)#interface fa 0/1

AS2(config-if)#switchport trunk encapsulation dot1q

AS2(config-if)#switchport mode trunk

AS2(config-if)#switchport trunk allowed vlan 10,40 R1(config)#interface fa 0/0

R1(config-if)#no sh R1(config)#interface fa 0/0.10 R1(config-subif)#encapsulation dot1Q 10 R1(config)#interface fa 0/0.40 R1(config-subif)#encapsulation dot1Q 40

14. Give R1 subinterfaces in VLANs 10 and 40. R1(config)#interface fa 0/0.10 R1(config-subif)#ip address 172.16.10.1 255.255.255.0 R1(config)#interface fa 0/0.40 R1(config-subif)#ip address 172.16.40.1 255.255.255.0

15. Create an SVI interface on DS1 in VLANs 20, 30 and 40. Create an SVI interface on

DS2 in VLAN 10, an SVI interface on AS1 in VLAN 30, and an SVI interface on AS2 in

VLAN 40. DS1(config)#interface vlan 20 DS1(config-if)#ip address 172.16.20.1 255.255.255.0 DS1(config-if)#no sh DS1(config)#interface vlan 30

DS1(config-if)#ip address 172.16.30.1 255.255.255.0 DS1(config-if)#no sh DS1(config)#interface vlan 40

DS1(config-if)#ip address 172.16.40.2 255.255.255.0 DS1(config-if)#no sh DS2(config)#interface vlan 10

DS2(config-if)#ip address 172.16.10.2 255.255.255.0

DS2(config-if)#no sh

AS1(config)#interface vlan 30

AS1(config-if)#ip address 172.16.30.2 255.255.255.0

AS1(config-if)#no sh

AS2(config)#interface vlan 40

AS2(config-if)#ip address 172.16.40.3 255.255.255.0

AS2(config-if)#no sh

Arbab Nazar Network Engineer

B.Sc. CE, M.Sc. Computer Networks

Page 6: 27816536 CCNP3 BCMSN Case Study 1

16. Enable IP routing on DS1. On R1 and DS1, configure EIGRP for the whole major network (172.16.0.0/16) and disable automatic summarization.

DS1(config)#ip routing

DS1(config)#router eigrp 1

DS1(config-router)#no auto-summary

DS1(config-router)#network 172.16.0.0

R1(config)#router eigrp 1

R1(config-router)#no auto-summary

R1(config-router)#network 172.16.0.0

Arbab Nazar Network Engineer

B.Sc. CE, M.Sc. Computer Networks